Mac-OS 升级 10-11 以后 cocoaPods 不能使用的解决办法

升级到10.11以后当我们终端输入命令行以后出现

1
-bash: pod: command not found

这是你之前如果有 cocoapods,但是输入比如 pod update 或者 pod install 之后命令失效,输入

1
sudo gem install -n /usr/local/bin cocoapods

然后在执行命令,就会解决

如果你没有装 pods 的话,之前我写过一篇教程

cocoapods 的安装与使用方法

注意的是以前的 taobao 路径是输入

1
gem sources -a http://ruby.taobao.org/

现在要变成

1
gem sources -a https://ruby.taobao.org/

现在的是 http 换成 https

执行 pod updatepod install 速度比较慢的问题

在国内嘛,你有可能就被墙了,所以就不要用 pod updatepod install 了,使用

1
pod update --verbose --no-repo-update

1
pod install --verbose --no-repo-update

来升级和安装。

如果出现 Operation not permitted - /usr/bin/xcodeproj 这个错误,可以使用

1
sudo gem install -n /usr/local/bin cocoapods --pre

来替代

1
sudo gem install cocoapods
若您觉得我的文章对你有帮助,欢迎点击上方按钮对我打赏!
------------- 本文结束 感谢您的阅读 -------------